青木メソッド(奇数のとき)

青木メソッドでは、2列になって立ち、2分たったら全員左に移動します。列からはみでたら向かいの列に移ります。参加者が奇数のときは必ず1名はみ出るので、順にはみ出た一人がタイムキーパーを勤めます。

例えば、A~Iの9名いるとしたら下のように向かい合わせに並んで立ち、Iの人がタイムキーパーとなります。

ABCD I

EFGH

2分たったら、全員向かって左に移動するので、下のようになり、Dの人がタイムキーパーになります。

EABC D

FGHI

これで1周すると全員が互いにペアとなって自己紹介しあうことができます。

自己紹介

いよいよ来週から授業が始まります。いろんな雑務に追われて準備どころじゃない状態ですが、昨年から持ち越しの問題をどうしようか悩み中です。

昨年の今頃の記事にも書きましたが、

http://d.hatena.ne.jp/nqthm/20060412/p2

でやった「青木メソッド」を今年もやろうと思っています。これは、クラス全員が次々にペアを変えながら自己紹介をしていくというものです。

自己紹介といえば一人が立って皆が聞くというパターンが多いのですが、これだと最初の方は緊張でうまくはなせないし、後の方は皆が飽きてきてつまらなくなるという問題があります。

そこで、全員が2列で向かい合って目の前にいる人と一定時間自己紹介しあい、時間がきたら隣の人と交代していきます。このメリットは、常に新しい相手なら飽きることはないし、同じ話をしても問題ないし、何より親密度が一気に増します。このおかげか、昨年のクラスは例年にない良い雰囲気で終えることができました。(デメリットとしては話しすぎてえらく疲れるということです)

vmwareでのNT4.0 Serverインストール

debianに引き続いてNT4.0サーバーをvmwareで使えるようにしてみました。

  • vmx-Makerというソフトウェアでnt用のvmxファイルを作成。
  • このとき、FDDを有効にする、FDDにイメージを割り当てを選び、FDDのイメージをFD.IMGとする。
  • Windows NT 4.0 ServerのインストールCDからi386\winnt32 /oxを実行し、インストールフロッピー(3枚)を作成。
  • marucopyというソフトウェアで作成した3枚のフロッピーのイメージを抽出。
  • 1枚目のフロッピーイメージをFD.IMGとする。
  • 先ほどのvmxファイルでvmwareを起動する。
  • あとはフロッピーの入れ替え時にタイトルバー上のFloppyをクリックして無効化し、2枚目3枚目のフロッピーイメージをFD.IMGにしてから再度有効化して作業を進めていく。

以上で無事にNT4.0サーバーがインストールされました。

vmx-Maker

http://www.vector.co.jp/soft/winnt/util/se386393.html

MARUCOPY

http://www.vector.co.jp/soft/dos/util/se010458.html

データ移行に失敗した理由

元のOracleデータベースに格納されていた日付が異常だったのが原因でした。

なんとかテーブルとビューの移行は完了したようです。あとはストアドプロシージャを何とかすれば何とかなりそう。

データベースのインポート

Oracleのデータインポートを試みます。

  • SQL Server Business Intelligence Development Studioを起動して、プロジェクトメニューから「SSISインポートおよびエクスポートウィザード」を選びます。
  • データソースの選択画面で、データソースに「Microsoft OLE DB Provider for Oracle」を選択し、プロパティを押す。
  • サーバー名にOracleのサービス名を入力し、接続のアカウント情報を入力する。
  • 接続のテストボタンで接続できることを確認。(嬉!)
  • 変換先の選択画面で、格納するデータベースを選択。
  • テーブルのコピーまたはクエリの指定画面で、「1つ以上のテーブルまたはビューからデータをコピーする」を選択。
  • コピー元のテーブルおよびビューを選択画面で、必要なテーブルを選択する。
  • 完了すると変換が開始される。
  • 「列コードページ情報を取得できません」の警告が出るが無視。

これでデータ移行が完了したと思ったんですが、単に移行するプログラムが生成されただけでした。で、実行ボタンを押したら無事にデータ移行できました。

ストアドプロシージャはどうするんだろう。

Oracleの再設定

Oracleのデータを取り込もうとしたところ、Oracleクライアントを入れ忘れていたので導入しました。

でもってplus33でDBに接続しようとしたら、

エラーが発生しました。ORA-12203: TNS:宛先に接続できません。

あれれ?ちゃんとつながっていたPCからもダメでした。

サーバーからは「@DB名」をつけると接続できませんでした。

実はPCのネットワークIDを何気なく変えたのが原因で、こういうときは\ORANT\NETWORK\ADMIN\LISTENER.ORAを修正しなければならないのでした。

ということで新しいPCからもつながりました。

データベースの作成

どこから手をつけるのかもよくわかってないのですが、とりあえずデータベースの作成から。

Microsoft SQL Server Management Studioなるものを起動して、データベースを右クリックし、新しいデータベースを選ぶとデータベースが作成できます。(データベース名欄に適当な名前を入れてOKを押す)

セキュリティ構成

SQL Serverではほとんどのネットワーク設定が無効になっているらしいのでインストーラの最終画面にあった「セキュリティ構成ツールを使用してください」をクリックして「セキュリティ構成」画面を起動しました。

「サービスと接続のセキュリティ構成」画面でリモート接続を選び、「ローカル接続およびリモート接続」「TCP/IPのみを使用する」を選ぶ。

SQL Server 2005のインストール

とある事情で導入することに。急きょメモリ1.5GBのWindows 2000マシンにインストールです。キーボードもマウスも余分に置くところがないので全部VNCを使って作業しています。

以下は何をしたかの備忘録。

  • SQL Server Server 2005セットアップを起動
  • システム構成チェックでMDACバージョンの最少要件がエラー
  • MDAC2.8SP1をダウンロードしてインストール(MDAC_TYP)
  • 再度、SQL Server Server 2005セットアップを起動
  • 「インストールウィザードにようこそ」画面の後で「次へ」のボタンが現れる。
  • 機能の選択画面で全部選ぶ。
  • 「規定のインスタンス」を選ぶ。
  • サービスアカウント画面で「ビルトインシステムアカウントを使用する」を選ぶ。
  • 認証モード画面で「Windows認証モード」を選ぶ。
  • 照合順序の設定画面はそのまま次へ。
  • エラーと使用状況レポートの設定画面はそのまま次へ。
  • インストールを押す。インストールには結構時間がかかります。
  • ディスク2を挿入。まだまだかかるみたい。

ようやく終了。